Gyre

Discussion in 'Product Review' started by SilentReefer, May 18, 2017.

  1. SilentReefer

    SilentReefer Well-Known Member

    My new coralvue Xf-150 has not impressed. I realized yesterday evening one side is not working. Not sure when this happened. I cannot remember exactly when I got this, March-ish, I think.

    Took apart and cleaned three times with no luck. No vinegar soak, just a toothbrush.

    Ordered a RW 15 to replace. Once I get the Jebao in, I'll take the Gyre to the Fish Tank for repair. Deep sigh!
     
    huntindoc and LJC6780 like this.
  2. huntindoc

    huntindoc RRMAS BOD Membership Director Staff Member

    Thanks for the info Mark. I've heard they were a little fragile and difficult to clean. A great idea, hopefully they will improve the implementation of it in the future.
     
    SilentReefer and LJC6780 like this.
  3. LJC6780

    LJC6780 RRMAS Supporter

    So mine decided to make some funky grinding noise tonight and I immediately thought of this post! I took it apart and cleaned it with a toothbrush as best as I could and put it back in. I'm hoping that did the job but I'll probably pull it tomorrow and run it in some vinegar or something to finish the job. I wasn't wanting to climb under there and find the plug and everything tonight so I went with what would make it stop grinding!

    I'll say that removing the first side, I noticed a small piece of rubber inside the blades. Apparently the lip of the guard broke off. I was able to get it back together but be careful pulling the blades off!!
     
    SilentReefer likes this.
  4. LJC6780

    LJC6780 RRMAS Supporter

    Totally didn't soak it yet but I did notice that when I set it back up it seemed to be much stronger in both directions! I guess a little build up really does bog them down!
     

Share This Page